Linux Suse 10.3 VMware Tools ESX 3.5
Netzwerk Probleme

Der gestrige Tag war nicht meiner …
Nach dem Reboot einer unserer Linux Server am Wochenende war die Netzwerkkonnektivität zu Teufel …

Ping von und zum Host funktioniert 1a – Auf alles andere Antwortet der Host von Remote nicht.
Lokal funktioniert z.B. SSH und HTTP – nur von extern nicht. Auch alle Verbindungen vom Host nach extern funktionieren nicht z.B. DNS anfragen.

Also flugs ein Backup aus Dezember in einen anderen Host eingespielt – das zeigt aber das selbe Problem 🙁

In den Tiefen unserer Infrastruktur fand sich aber auch noch ein längst vergessenes Backup aus November – und das geht – juhu.

Vom Ehrgeiz gepackt wollten wir aber nun schon eine Lösung für das Problem suchen.
Diese haben wir dann auch nach eine diff des etc Verzeichnis gefunden – im November wurden durch ein Update der ESX Hosts die VMware Tools aktualisiert.
Da der Host erst jetzt neu gestartet wurde – wurden die Änderungen auch erst jetzt aktiv.
Ein uninstall der Tools brachte die Linux Maschine wieder zum fliegen.

Nun sind die VMware Tools aber eine nützliche Sache und wir wollten auf diese auch nicht verzichten.
Nach einer erneuten Installation der Tools und einem anschließenden Reboot brachte die selbe Problematik wie vorher.

Nun gibt es auf der VMware Website an einer gut versteckten Stelle eine neuere Version der Tools vom 09 Dezember 2010.

Leider hab ich keine Readme gefunden in welcher Reihenfolge die rpm´s installiert werden müssen – hier meine Reihenfolge:
Es muss vorher das GTK installiert werden – dies lässt sich „einfach“ über YAST bewerkstelligen – wenn man denn eine SUSE 10.3 DVD im Schrank hat …

rpm -ivh open-vm-tools-kmod-7.4.8-317866.333045.sles10.i586.rpm
rpm -ivh open-vm-tools-common-7.4.8-317866.333045.sles10.i586.rpm
rpm -ivh open-vm-tools-nox-7.4.8-317866.333045.sles10.i586.rpm
rpm -ivh open-vm-tools-xorg-drv-display-10.15.0.0-0.317866.333045.sles10.i586.rpm
rpm -ivh open-vm-tools-xorg-drv-mouse-12.4.1.0-0.317866.333045.sles10.i586.rpm
rpm -ivh open-vm-tools-xorg-utilities-7.4.8-317866.333045.sles10.i586.rpm
rpm -ivh open-vm-tools-7.4.8-317866.333045.sles10.i586.rpm

rpm -ivh vmware-tools-kmod-7.4.8-317866.333045.sles10.i586.rpm
rpm -ivh vmware-tools-common-7.4.8-317866.333045.sles10.i586.rpm
rpm -ivh vmware-tools-nox-7.4.8-317866.333045.sles10.i586.rpm
rpm -ivh vmware-tools-7.4.8-317866.333045.sles10.i586.rpm

Leider wurde hierbei der vmxnet Treiber nicht mit installiert – das werd ich in aller Ruhe bei Gelegenheit rausfinden.

Gedächtnisstütze:
SMB Mount in der Service Console ESX 3.x:

mount -t smbfs -o username=USERNAME/DOMAIN,password=PASSWORD //SERVER/SHARE /LOKALER-MOUNTPOINT

SMB MOUNT ESX 4.x

VMXNET Treiber nach Installation der VM-Tools aktivieren:

/etc/init.d/network stop
rmmod pcnet32
rmmod vmxnet
modprobe vmxnet
/etc/init.d/network start

IPv6 in der Linux VM deaktivieren:

echo “alias net-pf-10 off” >> /etc/modprobe.conf.local
echo “alias ipv6 off” >> /etc/modprobe.conf.local
Reboot

Link Liste:
http://www.oreilly.de/german/freebooks/rlinux3ger/ch074.html
http://www.planetmy.com/blog/how-to-disable-ipv6-on-suse-linux/
http://www.strassenprogrammierer.de/vmware-tools-unter-linux-installieren_tipp_392.html
http://dertompson.com/2008/07/16/network-problems-with-linux-in-vmware-server/
http://packages.vmware.com/tools/esx/3.5latest/sles10/index.html
http://communities.vmware.com/thread/34972

Noch keine Stimmen.
Bitte warten...

Tags: , ,

Hinterlasse eine Antwort