Migration vCenter 4.1 zu 5.0

Ja grad steht die Migration von vCenter 4.1 zu 5.0 auf dem Plan

Hier werd ich mal meine Probleme Stück für Stück posten.

1. Problem

[INFO] Checking VMware vSphere Update Manager version...
[INFO] VMware vSphere Update Manager version is 4.1.0.6589.
[INFO] VMware vSphere Update Manager version is 4.1.0.6589.
[ERROR] VMware Update Manager version not supported for backup
[WARNING] VMware Update Manager does not satisfy migration prerequisite

[ERROR] Error: vCenter Server, VMware Update Manager or VCO did not satisfy migration prerequisites
[ERROR] Exiting...

Obwohl in der VMware Upgrade Doku drin steht:

Voraussetzungen

- Stellen Sie sicher, dass auf der Quellmaschine eine unterstützte Version von VirtualCenter oder vCen-ter Server installiert ist:
- VirtualCenter 2.5 Update 6 oder höher
- vCenter Server 4.x und Update-Versionen davon

Das Problem findet sich in folgenden Dateien

VMware-VIMSetup-all-5.0.0-456005\datamigration\vum\vumbackup.py

Zeile 18
ist --> supported_vum_ver_regex ='1\.0\.+|4\.0\.+'
soll -> supported_vum_ver_regex ='1\.0\.+|4\.1\.+'

VMware-VIMSetup-all-5.0.0-456005\datamigration\vpx\vcenterbackup.py

Zeile 12
ist --> supported_vc_ver_regex ='2\.5\.+|4\.0\.+'
soll -> supported_vc_ver_regex ='2\.5\.+|4\.1\.+'

VMware-VIMSetup-all-5.0.0-456005\datamigration\vco\vcobackup.py

Zeile 12
ist --> supported_vco_version_regex ='4\.0\.[0-9]+'
soll -> supported_vco_version_regex ='4\.1\.[0-9]+'

Einfach ändern – und schon fluppt es *g

Rating: 0.5/5. Von 1 Abstimmung.
Bitte warten...

Tags: , , ,

Hinterlasse eine Antwort